Can't run HelloWorld Sample: UnsatisfiedLinkError


by MostafaRizk

Can't run HelloWorld Sample: UnsatisfiedLinkError

I'm trying to run the HelloWorld sample. I imported the project and added the jar to the build path but when I try to run on my phone, I get this message:

11-12 10:45:50.545: E/AndroidRuntime(7796): java.lang.UnsatisfiedLinkError: Couldn't load gesture-classifier from loader dalvik.system.PathClassLoader: findLibrary returned null

I did a little bit of debugging and it seems the problem occurs when checking if Hub is initialized in the onCreate method in HelloWorldActivity. Any idea what the problem might be?
by @smngreenberg TL

Can't run HelloWorld Sample: UnsatisfiedLinkError

Thanks for the post!

A few questions to start:
  1. What IDE are you using?
  2. What are the steps you used to import the project? (For reference, the recommended procedure is in the docs)

Cheers,
Scott
by MostafaRizk

Can't run HelloWorld Sample: UnsatisfiedLinkError

Hey Scott, thanks for the prompt reply

I'm using Eclipse. The steps I took were essentially the same as the ones listed in the link except I imported the HelloWorld on its own and not the entire Eclipse folder. I deleted it from my workspace and followed the listed steps and everything worked properly.

Thanks!
by iperez_genius

Can't run HelloWorld Sample: UnsatisfiedLinkError

i am using android studio. I have setup everything and launched the AVD. My myo is connected to my laptop (i can ping it) but i can't start the helloworld app. Do i need to pair the device with the emulator?

Will the myo work in the emulator?

by @smngreenberg TL

Can't run HelloWorld Sample: UnsatisfiedLinkError

The Myo armband won't work with the emulator. Are you trying to run helloworld on the phone?

You'll also need to unplug your Myo from the computer in order for it to connect to anything (computer, phone, or otherwise) as it can't connect while plugged in.

Cheers,
Scott
by Abouelenin

Can't run HelloWorld Sample: UnsatisfiedLinkError

by MostafaRizk
Hey Scott, thanks for the prompt reply I'm using Eclipse. The steps I took were essentially the same as the ones listed in the link except I imported the HelloWorld on its own and not the entire Eclipse folder. I deleted it from my workspace and followed the listed steps and everything worked properly.Thanks!
Mostafa, I am using eclipse and still can not make the hello world sample work, can you tell me how you did it?
I can not run the file, as it says the selection can not be lunched
Moderator control